Alle Kategorien
Suche

Dubletten suchen in Excel - so geht's

Dubletten suchen in Excel - so geht's2:08
Video von Michael Hirtz 2:08

In der Tabellenkalkulation Excel können Sie verschiedene Daten verarbeiten. Um Dubletten zu suchen, gibt es mehrere Möglichkeiten.

Dubletten sind Mehrfacheinträge. Das heißt, das der gleiche Datensatz mehrfach vorhanden ist. Da meist nur ein Datensatz benötigt wird, können Sie die gesamte Tabelle auf Dubletten durchsuchen.

In Excel Dubletten suchen und löschen

Um aus einer vorhandenen Exceltabelle Dubletten herauszufiltern und zu löschen, können Sie den Filter anwenden.

  1. Markieren Sie den Bereich, in dem Sie nach Dubletten suchen wollen und klicken Sie anschließend auf "Daten".
  2. Dort wählen Sie unter "Filter" den "Spezialfilter" aus.
  3. Es öffnet sich ein Fenster. Dort wählen Sie "An eine andere Stelle kopieren".
  4. Legen Sie unter "Kopieren nach" eine Zeile fest, wo das Ergebnis angezeigt werden soll. Setzen Sie den Haken bei "Keine Duplikate" und schließend Sie mit "OK" ab.

Die so kopierten Zeilen enthalten keine Dubletten. Diese werden automatisch gelöscht.

Dubletten in Excel anzeigen

Sie können über Formeln ebenfalls nach Dubletten suchen und diese anzeigen lassen.

  1. Markieren Sie die entsprechenden Bereich in der Exceltabelle, welcher nach Dubletten durchsucht werden soll. Mit Hilfe der bedingen Formatierung können Sie Dubletten anzeigen lassen.
  2. Öffnen Sie über "Format" die "Bedingte Formatierung" und wählen Sie "Formel ist" aus. Nutzen Sie die Formel "ZÄHLENWENN" um festzustellen, wie oft ein Wert eingetragen ist. Beispiel: Formel ist =ZÄHLENWENN($A$1:$x$10;A1)>1 gibt an, das der Bereich von Spalte A1 bis Spalte X10 auf den wert aus Spalte A1 durchsucht wird und wenn der Wert mehr als einmal vorkommt dieser markiert wird. Die Markierung legen Sie über das Format fest. Dort stellen Sie die Farbe, die Schriftart und die Ausgabe des Wertes fest. Diese kann als Text, Zahl oder ähnliches erfolgen.
  3. Um schnell und effektiv nach Dubletten zu suchen, können Sie über die Tastenkombination "Strg" und "F" die Suche aufrufen und direkt nach bestimmten werten suchen. Gegebenenfalls können Sie diese gleich hier nun auch gleich ersetzen.

Verwandte Artikel

Redaktionstipp: Hilfreiche Videos